Friday, May 23, 2014

Powershell DIY: Install Powershell Updated


Below is the requirements and links to Powershell installations!  Please remember to meet all of the requirements before attempting to install Powershell.

Workstation Operating Systems:

Version
Operating systems supported
Requirements
- Windows XP
- Windows Vista
or
- Windows XP SP3
- Windows Vista SP1
- Windows 7*
-.NET Framework 3.0 for Powershell 2.0
-.NET Framework 3.5 for Powershell 2.0 ISE
Powershell 3.0***
- Windows 7 SP1
- Windows 8**
  Or
Powershell 4.0****
- Windows 7 SP1
- Windows 8.1#
*Windows 7 has Powershell 2.0 and Powershell 2.0 ISE  installed natively
**Windows 8 has Powershell 3.0 and Powershell 3.0 ISE  installed natively
Server Operating Systems
*** Powershell comes in the Management Framework 3.0 package
****Powershell comes in the Management Framework 4.0 package
# Windows 8.1 has Powershell 8.1 Installed natively

Version
Operating systems supported
Requirements
- Windows Server 2003
- Windows Server 2008##

- Windows Server 2003 SP2
- Windows Server 2008 R2
-.NET Framework 3.0 for Powershell 2.0
-.NET Framework 3.5 for Powershell 2.0 ISE
Powershell 3.0***
- Windows Server 2008 SP1
- Windows Server 2008 R2 SP1
- Windows Server 2012

  Or
Powershell 4.0****
- Windows Server 2008 R2 SP1
- Windows Server 2012
*** Powershell comes in the Management Framework 3.0 package
            ****Powershell comes in the Management Framework 4.0 package


##Optional Feature

No comments:

Post a Comment